PDA

View Full Version : Exiting znes problem



zubaran
03-12-2010, 11:09 AM
Hello,

When i exiting "znes" emulator SNES with the "ESC" key i'm going back to the emulator GUI, not on HS. :hmmmm2:

I really don't know why :/

Can you help me to go back to HS when pessing the ESC key plz.

I use this configuration :


snes.xml :

[exe info]
path = E:\07 - Borne d'Arcade\Snes\Emulateur\
rompath = E:\07 - Borne d'Arcade\Snes\Roms\
userompath = true
exe = zsnesw.exe
romextension = zip
parameters =
searchsubfolders = false
pcgame = false
winstate = HIDDEN
hyperlaunch = true


Hyperlaunch configuration :

else if (executable = "zsnesw.exe")
{
hideDesktop()
SetKeyDelay, 250
Hotkey, %exitEmulatorKey%, CloseProcess
RunWait, %Executable% "%romPath%%romName%%romExtension%", %EmuPath%
}

Thanks

SophT
03-12-2010, 05:11 PM
you need to set the exit key in the emulator to close instead of 'open menu'

glassbox
03-14-2010, 04:18 PM
i've run into the problem with znes of not being able to remap the exit key to 'esc' because by default 'esc' clears the field in znes's gui. i cant seem to find any text config i can manually change either :\

ACE
03-14-2010, 08:35 PM
Go to 'misc' tab.... click 'misc keys'... map your escape key here.

I also have (in misc/GUI options) "escape to game menu" (not sure if u need too... just stating)

NEXUS9
03-15-2010, 10:50 AM
I just unchecked "escape to game menu".

glassbox
03-15-2010, 02:15 PM
i dont even have these options you speak of... i guess i should update znes

glassbox
03-15-2010, 02:39 PM
nope, same problem. you cant map the esc as exit.

i could map it to something else, i could also map a different key to open the menu. but i can not unmap esc as open menu and remap it as exit game.

which means i need a work around... is there anyway i can have AHK remap esc to... i dont know, Q or ~ ?

EDIT

Found this on BYOAC, confirmed to work (score)


Alright, this puzzled me for a little while, but the solution was actually pretty simple.

ZSNES has a built-in option to set a single key as a quit shortcut, located in its menu under:

MISC->MISC KEYS->QUICK KEYS->EXIT

The only problem with this being that when you click it to set the key, it tells you quite clearly:

"Enter the key or button to use (ESC to clear)"

Meaning that you can't simply set ESC to that function through the GUI, because it interprets you pressing ESC as "I don't want any key to do this" instead of "I want the ESC key to do this"

But, of course, this settings is simply stored in the program's config file! So open that up with notepad and find the setting "KeyQuickExit" If you don't have a key set, it'll read as "KeyQuickExit=0" the setting you want for it to be ESC is "KeyQuickExit=1"

Now if you'll boot up ZSNES and look at the MISC KEY menu again, you'll notice the EXIT function is set to ESC (just don't click it unless you want to edit the config file again Tongue). Now you're good to go! Whatever oddness causes ZSNES to wig out and not close properly using mala's hotkey is no longer a problem since you're not using a hotkey. Cheesy

leoouthouse
03-19-2010, 03:32 AM
Hey guys its simple you should set gui0ff=1 in znesw.cfg
Open zsnesw.cfg with notepad and edit the following line from "guioff=0" to "guioff=1". this will disable the GUI, making changes impossible from within the application. You can change this back at any time to make configuration changes via the main menu. This SHOULD cause ZSNES to exit the app and back to HyperSpin with the ESC key.

belikeb3
01-11-2013, 03:00 PM
none of the above are working for me.
when i set quickkeyexit=1, it does show esc in the misc option inside znes, but it still does not work
also if i set guioff=1 it will not let me even open the emulator anymore.
im using windows 7, latest version off znes

fudgeyall
01-11-2013, 03:11 PM
none of the above are working for me.
when i set quickkeyexit=1, it does show esc in the misc option inside znes, but it still does not work
also if i set guioff=1 it will not let me even open the emulator anymore.
im using windows 7, latest version off znes

I had a similar issue. I switched to SNES9x and haven't looked back. Good luck

Angelus_EV
06-14-2013, 02:39 PM
i need to use multiple keys for exit, (m & j) can anyone help me?

Angelus_EV
06-17-2013, 05:10 AM
I have a problem, no matter the SNES emulator I use, I can not exit with the key combination I choose.
here it is:

[HyperLaunch]
Last_System=Super Nintendo Entertainment System
Last_Rom=Mortal Kombat 3 (USA)
Exit_Script_Key=~q & ~s
Exit_Emulator_Key=m & j
Toggle_Cursor_Key=t
MultiGame_Key=NumpadSub
MultiGame_Select_Key=Enter
MultiGame_Exit_Key=Esc
Path_To_Daemontools=
Path_To_CPWizard=
Fade_In_Interrupt_Keys=anykey
Keymapper_Path=
Keymapper_Profiles_Path=C:\Hyperspin\Keymapper Profiles\

not so with kega fusion ....
I have no esc button in my control panel, I use the buttons (P1 start + P2 start) at the same time to exit emulators
as you can see:
P1 start = M
P2 start = J

whit some .ahk scrips it seems to work, but the Player 1 control is useless, the if i edit the .ahk the control return but no more exit

its weird coz the j and the m buttons are useable

bleasby
06-27-2013, 04:18 AM
try to change your exit key for:
Exit_Emulator_Key=~m & ~j

Also, you should add and edit anything on HyperLaunch using HyperLaunchHQ.

Update to HyperLaunch 3.0 and use HyperLaunchHQ for everything and you sholdn't have any issues like that anymore.